Success rates with the X Ads connector have returned to normal. We are continuing to monitor the connector closely to ensure there are no further issues.
Posted Apr 02, 2026 - 18:11 EEST
Investigating
We are aware of elevated error rates with the X Ads API which is affecting the X Ads connector. We are currently monitoring the situation closely and will provide updates as soon as they are available.
Posted Apr 02, 2026 - 16:19 EEST
This incident affected: Data sources (Twitter Ads).